2

I have been using Mendeley for a while to create my bibtex files and use them in Latex. However, recently I came accross some papers such as this one, which have math symbols in their titles and when I try to create an entry in Mendeley and use it in my Latex document the title gets messed up. How can I create a Bibtex file containing papers with math symbols in their titles via Mendeley?

I've tried to type the code on the title section on Mendeley but it doesn't seem to work. Thanks!

1

Mendeley defaults seem to be to automatically escape LaTeX special characters, which can mean math mode text gets mangled. In my version (1.19.4), this can be changed by going: Mendeley Desktop -> Preferences -> BibTeX and unchecking Escape LaTeX special characters (#{}%& etc.)

Edit: once you've done that you can include math mode markup in your titles, as suggested by @Federico Poloni, e.g. {$2^2$}, and it will not be mangled by Mendeley.

This will mean that all special characters will not be escaped, so you'll have to do it by hand otherwise your compile will likely throw errors. For instance titles including & will need to escaped manually (e.g. \&) in Mendeley.

0

I am not a Mendeley user, but have you tried putting the math formulas inside braces, e.g., title = "A new proof of {$a^2+b^2=c^2$}"? This is the proper Bibtex syntax to include math in paper titles.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.