3

Hi Google Scholar changes my profile into Thai language, how do I change it back? My Google account language is English. I contacted Google several times but never got any response: Google seems don't have any client service, disappointed...


Thank you very much @Anton @GoodDeeds @ Solar Mike. I tried the way shown by Anton and find my own language setting is already English. I also know the way to manually change the display languages by GoodDeeds. The problem I encountered is that whenever other people searching my name in Google, my Google Scholar profile will be popped up, which shows only in Thai. I hope to find a way to let Google Scholar automatically display the languages in English as what they did before. The main purpose is to help others to read my profile in English. This problem happened about one year ago, I contacted two or three times Google through certain online feedback form, but was never replied and the problem was never corrected. I will probably try to use Twiter or Facebook to contact Google

  • 2
    If you want to complain about Google direct your complaints to them - even try facebook and twitter. – Solar Mike May 24 at 13:24
6

Visit your GS profile, and go to settings section, where you will be able to handle Languages. Direct link is: here

| improve this answer | |
5

You can change your language preferences in your settings, as has already been mentioned in the other answer. In general, however, if you come across a profile in a different language (for example, via Google Search), or if you are logged out / don't have an account, you can change the language by modifying the URL of the profile page.

To do this, just add the query parameter hl=en at the end of the URL (replace en appropriately for viewing in a different language). For example, change

https://scholar.google.com/citations?user=<id>

to

https://scholar.google.com/citations?user=<id>&hl=en

for viewing the profile in English. Usually a language is already specified in the URL via this parameter, so you could either override it by appending a new value to the end or fix it by modifying the existing string.

Also note that following an URL that already has a language specified will override your settings. So if you click on a profile from Google Search that contains the hl=fr parameter, the profile will load in French even if you have set your language preference to English, and this can be fixed as described above.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.